Flex enquiries delay
Incident Report for Entegral
Resolved
This incident has been resolved.
Posted 8 days ago. Jan 09, 2019 - 11:52 SAST
Investigating
We are aware of a delay in enquiries through Flex websites, our team is busy investigating.
Posted 8 days ago. Jan 09, 2019 - 11:42 SAST
This incident affected: Flex websites.