www.entegral.net / www.entegral.biz
Incident Report for Entegral
Resolved
This incident has been resolved.
Posted 5 months ago. Apr 05, 2019 - 14:45 SAST
Identified
Entegral website currently down. Service provider is working on getting this resolved as soon as possible.
We are unable to provide an official time-frame for when the service will be restored. We apologize for any inconvenience this may cause.
Posted 5 months ago. Apr 05, 2019 - 12:57 SAST