Entegral Technologies - Alternative Support Email address
Incident Report for Entegral
Resolved
This incident has been resolved.
Posted 5 months ago. Mar 26, 2019 - 11:31 SAST
Investigating
Dear Customer,

We are aware of an issue causing intermittent email delivery failures to our support@entegral.net email address.

Our Engineers are investigating the root cause of the issue. As soon as we have some feedback we will send out an update.

Please send any enquiries to support@entegral.biz

Apologies for the inconvenience to your business
Posted 5 months ago. Mar 26, 2019 - 08:25 SAST
This incident affected: ValueMail.